Please select Into the mobile phone version | Continue to access the computer ver.
Close
You need to log in before you can reply       Login | Register now

[Help] Qt Creator onboardSDK sample ERROR

Author: Eduardo0 2017-2-23 11:19
3 342
Last edited by Eduardo0 In 2017-2-23 12:32 Editor

So, I tried to execute the onboardSDK sample, I type in the ID and password, I open the COM without any problems and get:
STATUS QtOnboardsdkPortDriver::init,line 35: port COM5 open success
STATUS QtOnboardsdkPortDriver::init,line 42: BaudRate: 230400

Then I hit "Activate" button and I get this error:
ERROR DJI:nboardSDK::CoreAPI::activate,line 388: Please call getDroneVersion first.


I assumed it was because I had to click on the "version" button, but when I do absolutely nothing happens, no message, no nothing.

Ideas??


Reply
Replies
Skylark1
Hey I'm having the same problem... did you get around this at all ? thanks
2017-3-7 09:14
Abdullah2054
Hello. I have a same problem. I am using Jetson Tegra board tk1. It is running 14.04 ubuntu. Tried everything and still it is showing the same error !! Is it happening for update error ? Please anyone answer it. I need urgent solution. Now feeling so hopeless. Any kind of help is appreciated.
2017-3-9 19:58
djiuser_yTFC06E
I had the same problem. Change COM port is nothing happens, verify your ttl-usb connection. In my case, TxD and RxD were switched.
2017-7-20 06:06
You need to log in before you can reply Login | Register now

Quick Reply Back to top Back to list
Quick Reply Back to top Back to list