Please select Into the mobile phone version | Continue to access the computer ver.
Close
You need to log in before you can reply       Login | Register now

[Bug] Guidance with ROS

Author: dintere 2016-6-15 21:25
3 4107
Hi,

I'm currently setting up a system under Ubuntu 14.04 and ROS Indigo. I followed precicely every step described in the tutorial, installing the USB driver by hand and compiling the guidance source within my catkin workspace. So far so good everything worked fine.

In the tutorial as well as in the Readme file are instructions to test the installation. In the tutorail it is suggested to run sudo ./guidance_example, in the readme launching rosrun guidance guidanceNode and rosrun guidance guidanceNodeTest is adviced. I have tried both but without succes. Calling sudo ./guidance_example fails as I cannot find the correct files in the workspace and rosrun cannot find the package guidance.

I think there is something messed up in the tutorials and it would be nice to have some advice how to proceed to verify the correctness of my installation.

Thank you.

Reply
Replies
DosBobs
Are you using the Guidance SDK or the Guidance SDK ROS?

Here are the ROS instructions.   You should be using either rosrun or roslaunch to execute ros code
https://github.com/dji-sdk/Guidance-SDK-ROS
2016-6-16 22:22
dintere
Thank you for your answer. Of course I cloned the Onboard-ROS repository as well as the Guidance-SDK-ROS repository. Compiling was no problem and I tried my best to set everything up correctly as it is described in the manual.

For testing I followed the instructions and after launching roscore I executed rosrun guidance guidanceNode in a new Terminal. Unfortunately it couldn't be resolved, prompting the error :

rosrun: command not found

Launching the guidanceNodeTest has the same problem. I assume that I have some problems with my path, but I'm not sure how to resolve this issue.

I have some troubles with the onboard sdk, too. Perhaps these issues are related. So feel free to watch my post in the onboard forum.

Thanks a lot!
2016-6-29 21:34
noppadol.pudchu
Are you source  ~/home/"your user"/"your catkin work spaces "/devel/setup.bash
You must be source /devel/setup.bash every time if you open a new terminal. or you can put it to .bashrc for your facilities
Sorry about bad language
2016-10-26 01:26
You need to log in before you can reply Login | Register now

Quick Reply Back to top Back to list
Quick Reply Back to top Back to list