Please select Into the mobile phone version | Continue to access the computer ver.
Close
You need to log in before you can reply       Login | Register now

[Bug] USB Example Issue

Author: nerdsboredom 2015-11-21 05:51
2 4146
when I run usb example on raspberry pi, I get the following error
Error while loading shared libraries : libDJI_guidance.so: cannot open shared object file : No such file or directory.

I have copied the libDJI_guidance.so from so/arm directory to both /usr/local/lib and the directory of the excutable but its not working. I was wondering if you can upload a version of library compile with a newer version of cross compiler instead of 2010q1/arm-none-linux-gnueabi-g++ or http://gnutoolchains.com/raspberry/ (this is my compiler)

or do you think if the issue is something else please guide.

Thanks,
Reply
Replies
nerdsboredom
when I run ldconfig -v, I can see the library found by the linker but I am not sure I am seeing this error when I run the program.

libDJI_guidance.so (libc6) => /home/pi/Guidance-SDK/examples/usb_example/DJI_guidance_example/libDJI_guidance.so

but when I run
# ldd guidance_example  | grep libDJI_guidance.so
        libDJI_guidance.so => not found

Please help!!!
2015-11-24 01:45
nerdsboredom
Last edited by nerdsboredom In 2015-11-24 23:43 Editor

I figured it out myself. Thanks to the worst technical support. I ended up using the .so under XU3 (which is arm7) and everything started working magically
2015-11-24 23:38
You need to log in before you can reply Login | Register now

Quick Reply Back to top Back to list
Quick Reply Back to top Back to list