Please select Into the mobile phone version | Continue to access the computer ver.
Close
You need to log in before you can reply       Login | Register now

[Device] Upgrading firmare

Author: Tbowardcnu 2016-4-11 05:25
18 9699
Trying to upgrade the firmare. When I turn on the m100 I get a constant beep and one flash of light on the tail light. Then just the beeping. Will not connect to my pc through the usb cable. Any thoughts?

Also is there a reset button?

Thanks in advance.


Todd Boward
Reply
Replies
2801
Last edited by 2801 In 2016-4-11 19:53 Editor

I have the exact same problem. The new Firmware Upgrade failed for some reason and since then the Drone keeps beeping. It´s not getting recognized by the PC / Assistant either.

Help would be greatly appreciated.

Update:
I happen to still have the old DJI Assistant and at least the old Software recognizes the Drone. Apparently the Drone got reset to Firmware 1.0.0 for some reason, at least thats what the old Assistant says. Unsure wether i should update it trough the old assistant now or not. Around 10/20 minutes of potentially annoying beeping is what has kept me from that idea so far. Probably going to try it later anyway.
Thought that information might be helpful.

Greetings,
Nikolai S.
2016-4-11 19:21
Kevin8
Todd,
This seems to be a consistent issue with the M100.
YOu will need to have the most updated assistant and firmware. Especially with all the updates in the past month!

One day, we need to post the full workflow.
Most PC's do not see the M100 at all since it doesn't have the correct driver.
When you load the DJI windriver, the PC wont accept it because of a windows security issue.

1-Restart PC (Hold shift and click restart)
2-Select "Troubleshoot" when it has rebooted
3-Select "Advanced options"
4-Select "Startup Settings"
*Select "disable driver signature enforcement"
F7 key
After another reboot, load DJI assistant + Windriver+whatever else you want.

I am sure the other teams in the DJI challenge have this figured out but, EVERYONE has had this issue in the States!
2016-4-12 23:09
Tbowardcnu
Kevin8 Posted at 2016-4-12 23:09
Todd,
This seems to be a consistent issue with the M100.
YOu will need to have the most updated as ...

Kevin,

Going to try this today! Thank you for the input. will post what the status is.

Thanks again!
2016-4-13 02:24
jespestana02
Hi both!

We are facing the same problem as Todd Boward. We started the DJI Assistant 2, and it prompted us to perform an upgrade of the DJI Matrice M100 firmware. The firmware update was unsuccessful and crashed some time in the middle of the update. Following the instructions from the DJI Assistant 2, we powered the M100 off.

We have already followed Kevin's instructions. As far as I can tell this did not changed anything in our situation.

Since then:
  [] We cannot connect to the M100 from the computer anymore.
  [] Everytime we power the M100 on it will start beeping "D-D-D-...". After some time powered on the beeping pattern changes. We have tried to wait more than 25 minutes (as recommended in the M100 manual) before powering off and on again. The behavior stays the same, and the computer does not detect the M100.

Tomorrow we will try to perform the firmware update using the Zenmuse X3 (by putting the firmware update on the SD card, this is a different firmware update method suggested in the M100 manual).

We will be following your updates
Thanks in advance,
2016-4-14 01:32
Kevin8
jespestana02 Posted at 2016-4-14 01:32
Hi both!

We are facing the same problem as Todd Boward. We started the DJI Assistant 2, and it prom ...

Sorry to hear about it still not working.
I promise you that the WIN_Drive_installer is the issue and its a Microsoft solution on PC.
Please try to install the battery and firmware using the SD card.
You can then view the .TXT file to confirm load or failure on the SD after 20 min..and the Beeping will change. Please let us know if that works!
KP
2016-4-14 03:11
smootar
Kevin8 Posted at 2016-4-14 03:11
Sorry to hear about it still not working.
I promise you that the WIN_Drive_installer is the issue ...

I have the same problem with the new update, it seemed to fail in the middle of the update. I have installed the Win_Drive (usbser.sys) successfully without error.  It seems like the M100 probably has an old version of the driver and won't talk to the PC (Windows 7) anymore. It was talking just fine up until it failed in the middle of the update. I currently without a camera, so I don't have a way to update the firmware on the M100. I do have a Zenmuse X3 that should be here tomorrow. I'm hoping that this will fix my problem and I will be up and running.  It would be nice to get some instructions on how to update the firmware without the camera (if that is possible). If there is a way, please send the steps to me tonight and I will try it out and post my results. I'm sure this will help others in the future. Thanks.
2016-4-14 08:46
lanyusea
hi all,

could you send the log of DJI Assistant to me ? I will try to figure out what's going on.

type
%appdata%\DJI Assistant 2\log
in the address of your file explorer .

pack everything and send it to lanyusea[at]gmail.com
2016-4-14 11:06
smootar
Last edited by smootar In 2016-4-14 12:48 Editor
lanyusea Posted at 2016-4-14 11:06
hi all,

could you send the log of DJI Assistant to me ? I will try to figure out what's going on.

I zipped up all of the log files and have sent them to you. They should be in your inbox.

Thanks.
(I also attached them here)

This post contains more resources

You need to Login Before they can download or view, Not have an account?Register now

x
2016-4-14 12:40
jespestana02
Hi again,

Okay. We were able to finish the firmware update of the M100 to the firmware version V1.3.1.00. Now the M100 is detected by the DJI Assistant 2, and we can configure it.

This is what we did. We connected the Zenmuse X3 to the M100 using the Gimbal mount. Then we placed the newest firmware file ( MATRICE100_FW_V01.03.01.00.bin ), from http://www.dji.com/product/matrice100/info#downloads , on an SD Card (formatted using exFAT) and we put the SD card on the Zenmuse X3. Upon powering on the M100, the Gimbal started moving (we guess doing some kind of calibration) and the M100 started beeping like yesterday. Then the Gimbal kept doing always the same small rhythmic motion over and over again, will the M100 continued to beep (same as before). After 15minutes, the beeping stopped and the M100 status light was flashing in an all-color sequence. We decided to wait until the 25minutes  specified in the manual and powered off the M100.

We are pretty sure that it worked, so we will just continue with the testing that we had planned
Thanks for your advice!

PS: Note that we already configured the windows computer as specified by Kevin8

2016-4-14 18:39
smootar
I think those that have read other posts know that the M100 can be reset if you have a camera. My situation is doing this without the camera. Is there a way to reset and install the firmware if you do not have a camera? Has anyone solved that puzzle?

(Note: I have a camera being shipped to me so my problem will hopefully be remedied, but I have been stuck waiting for that to get around this problem. But there may be others that would like to reset the M100 that do not have a camera).
2016-4-14 21:06
Kevin8
jespestana02 Posted at 2016-4-14 18:39
Hi again,

Okay. We were able to finish the firmware update of the M100 to the firmware version V1.3 ...

Great job!
That method worked for us originally.
2016-4-15 00:42
Kevin8
smootar Posted at 2016-4-14 21:06
I think those that have read other posts know that the M100 can be reset if you have a camera. My si ...

The only method without Z3/Z5 is DJIASsistant.
DJI_WIN_Driver
USB connection to M100.
When you connect you can actually see the DOS prompt.
Ill look at your .Zip and post back
2016-4-15 00:44
Kevin8
Kevin8 Posted at 2016-4-15 00:44
The only method without Z3/Z5 is DJIASsistant.
DJI_WIN_Driver
USB connection to M100.

NEW firmware updates available!!
GOOD LUCK!
2016-4-18 22:25
DonatelloDaRuby
Can someone please post a video of updating the firmware of the matrice 100? Or if if possible. message me with a way that we can speak by phone. I continually am getting "command timeouts" when attempting to fly the matrice. Any advice?

Cheers,
2016-6-24 02:26
xboxgamerpro-sp
Hey guys looking for some help on this. I have a Phantom 3 Advanced and I was trying to update firmware on RC and Transmitter. I successfully updated on RC, however I believe I might have accidentally removed sd card reader from Transmitter before firmware was completely updated. Are there any fixes for this?  (When I insert sd card in transmitter with appropriate latest firmware .bin file nothing happens. The light stays red with battery indication illuminated that is all. After 60 seconds and many more minutes no update has started. Any help is greatly appreciated.

Thanks, Brad.
2016-6-25 10:18
sandyhanu1995@g
yep. i like this topic
play Tiny Tanks   
2016-7-23 13:15
mortality
indeed, this is very interesting topic, thank you author

visit my website: food near me
2016-8-26 20:09
tt5ZISCtBi74
I have the exactly same problem as you. I fixed it by the repair version of dji assistant software. You should first put this file in your install path. Secondly, connect the matrice 100 with your computer and run the software. The noise of your drone will disappear and everything will be ok.

This post contains more resources

You need to Login Before they can download or view, Not have an account?Register now

x
2017-3-7 17:41
You need to log in before you can reply Login | Register now

Quick Reply Back to top Back to list
Quick Reply Back to top Back to list